Problem with discharge

MOHID Land forum. Questions and discussion related to MOHID Land
cyril.garneau@ensat.fr
MOHID Beginner
Posts: 4
Joined: Wed Mar 21, 2012 16:04

Problem with discharge

Postby cyril.garneau@ensat.fr » Fri Sep 25, 2015 17:48

Hi,

I have a very simple river network consisting of a single river with a basin in which I want to model sedimentation. As I had some problems with my old MOHIDRiver executable, I tried to update my model with the new one available with Mohid Studio 2015. However, the discharge module is causing trouble. I can use the discharge to add flow to my model, but no cohesive sediment. If I do, I get the following error:
forrtl: severe (157): Program Exception - access violation
Image PC Routine Line Source
MOHIDRiver_releas 00000001400B08F0 MODULEDISCHARGES_ 3418 ModuleDischarges.F90
MOHIDRiver_releas 000000013FF89E5D MODULEDRAINAGENET 10273 ModuleDrainageNetwork.F90
MOHIDRiver_releas 000000013FF867D5 MODULEDRAINAGENET 9203 ModuleDrainageNetwork.F90
MOHIDRiver_releas 000000013FF92CF9 MODULEDRAINAGENET 9092 ModuleDrainageNetwork.F90
...

I looked in the source code and cannot find clues to solve my problem. For information, my discharge file is:
<begindischarge>
NAME : B1
NODE_ID : 2
DEFAULT_FLOW_VALUE : 0.001
DATA_BASE_FILE : ..\General Data\Boundary Conditions\Input_bassin.txt
FLOW_COLUMN : 2
<<beginproperty>>
NAME : cohesive sediment
UNITS : mg/L
DESCRIPTION : SS
DEFAULTVALUE : 0.001
DATA_BASE_FILE : ..\General Data\Boundary Conditions\Input_bassin.txt
TIME_SERIE_COLUMN : 3
<<endproperty>>
<enddischarge>

And my input file looks like:
TIME_UNITS : SECONDS
SERIE_INITIAL_DATA : 2014 4 30 12 0 0
NAME : Bassin inputs
Time Flow cohesive_sediment
<BeginTimeSerie>
0 9.21E-03 7.54E+00
3625.43 1.10E-02 4.58E+03
...
<EndTimeSerie>


Any idea on what I did wrong?

Thank you,

Cyril

davidbrito
MOHID Advanced user
Posts: 189
Joined: Thu Jan 01, 1970 00:00

Re: Problem with discharge

Postby davidbrito » Tue Mar 28, 2017 09:31

Hello Cyril,

Sorry for the delay.

The MOHID River Network had some code change. Can you update the MOHID code and try? or I can send you an exe.

If the problem still persists let me know.


Best regards,
David


Return to “MOHID Land”

Who is online

Users browsing this forum: No registered users and 1 guest