Errors while run process

MOHID Land forum. Questions and discussion related to MOHID Land
epelde.ane@gmail.com
MOHID Advanced user
Posts: 172
Joined: Thu Jan 01, 1970 00:00

Errors while run process

Postby epelde.ane@gmail.com » Mon Jan 16, 2012 16:15

Hello all!
I wonder about this error, which appeared after changing some keywords to a simulation and setting two diferent soils.
I copy here the log so that maybe you can give me a hand! :)
It says:

Constructing Mohid Land
Please Wait...

-------------------- DRAINAGE NETWORK --------------------

Number of Nodes : 594
Number of Reaches : 593
Number of Outlets : 1
Hydrodynamic Approx. : Kinematic wave
Numerical Scheme : ExplicitScheme
Downstream Boundary : Zero depth gradient

forrtl: error (65): floating invalid Image PC Routine Line Source
MOHIDLand_release 00565170 _MODULEFUNCTIONS_ 3618 ModuleFunctions.F90
MOHIDLand_release 0042F9BD _MODULEPOROUSMEDI 5469 ModulePorousMedia.f90
MOHIDLand_release 0042A9ED _MODULEPOROUSMEDI 629 ModulePorousMedia.f90
MOHIDLand_release 004D4288 _MODULEBASIN_mp_C 2251 ModuleBasin.f90
MOHIDLand_release 004CD7D4 _MODULEBASIN_mp_C 614 ModuleBasin.f90
MOHIDLand_release 004F190A _MAIN__ 72 MohidLand.f90
MOHIDLand_release 00822BA3 Unknown Unknown Unknown
MOHIDLand_release 0077BA4C Unknown Unknown Unknown
kernel32.dll 75A71114 Unknown Unknown Unknown
ntdll.dll 7753B299 Unknown Unknown Unknown
ntdll.dll 7753B26C Unknown Unknown Unknown


Thanks!

davidbrito
MOHID Advanced user
Posts: 187
Joined: Thu Jan 01, 1970 00:00

Re: Errors while run process

Postby davidbrito » Mon Jan 16, 2012 17:03

Hello,

you have a problem in defining the initial condition for theta probably.


I would suggest to go from the run that works into the direction of the new run and you will see what change makes the model to crash.

Best regards,
David

epelde.ane@gmail.com
MOHID Advanced user
Posts: 172
Joined: Thu Jan 01, 1970 00:00

Re: Errors while run process

Postby epelde.ane@gmail.com » Tue Jan 17, 2012 14:39

I picked a simulation which run without any problem and after changing the climatic data (from hourly to 10min data) I got an error. I think I checked everything but no idea why is this appearing. It says: StartTimeSerieInput - ModuleTimeSerie - ERR21
Any idea please???

epelde.ane@gmail.com
MOHID Advanced user
Posts: 172
Joined: Thu Jan 01, 1970 00:00

Re: Errors while run process

Postby epelde.ane@gmail.com » Thu Feb 02, 2012 10:54

Hello again!

As you said, I took a simulation which didnt crash, and I made the following changes:
First, I add more layers in geometry module (so that I had to change the bottom file into a new one created automatically). Then, I set as a initialization method an asci file and wrote the properties for two soils. then, I run it and it crashed.
The error that appeared is the same as I wrote before, the error65. Although before, I had a similar one (error 172) and I manage to fix it up changing the hydraulic properties, so i dont know if the problem can come from there as well..

Any help please??
Thanks

davidbrito
MOHID Advanced user
Posts: 187
Joined: Thu Jan 01, 1970 00:00

Re: Errors while run process

Postby davidbrito » Tue Feb 28, 2012 19:12

Hello Ane,

the fisrt error about timeserieinput. If the only thing was to change the timeseries than you have an error in the timeserie file. or tabs or blanks. try to open the time serie file in studio or in timeserie editor. it will probably complain. when it opens in these programs than it is ready.


the second error about changing soil properties. so if the model crashes when you had a grid, I would suggest to put in the grid only one soil, so all the cells with the same value (1). and in the soil database it has to appear also the soil 1 defined.
If this go weel than you can start putting more soils (2, 3, 4, 5...) and defining their properties. Remind that the soil IDS have to be consecutive and starting by one. meaning cant have defined in <beginsoiltype> <endsoiltype> soils 10, 20 and not having from 1 to 10 and from 10 to 20.


David


Return to “MOHID Land”

Who is online

Users browsing this forum: No registered users and 1 guest